Supported Browsers for vCloud

vCloud
 Purpose: To provide students with information about the web browsers supported by vCloud.

The vCloud web portal for accessing virtual machines (VMs) supports only certain web browsers. Currently, Mozilla Firefox is the only browser that will connect with our environment.

Note: Only 32-bit versions of this browser is supported by vCloud. If you are experiencing problems, make sure that you are using a 32-bit versions of your chosen web browser. Also, vCloud relies on the following browser plugins:

  • Adobe Flash Player, version 11.2 or newer. Only the 32-bit version is supported.
  • Java Runtime Environment (JRE) version 1.6.0, update 10 or newer. Only the 32-bit version is supported.
  • SSL/TLS encryption is required by vCloud. Supported versions include SSL 3.0 and TLS 1.0,1.1 and1.2. These are usually built into most web browsers.
  • VMware Remote Console (VMRC) Plugin, version 5.1.x. You will be be prompted to install this plugin when you access vCloud for the first time, and when there are major updates to the plugin.